1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950 |
- #!/usr/bin/make -f
- # See debhelper(7) (uncomment to enable)
- # output every command that modifies files on the build system.
- #export DH_VERBOSE = 1
- # see FEATURE AREAS in dpkg-buildflags(1)
- #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
- # see ENVIRONMENT in dpkg-buildflags(1)
- # package maintainers to append CFLAGS
- #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
- # package maintainers to append LDFLAGS
- #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
- build:
- cargo build --release
- binary-arch: build
- binary-indep: build
- binary: binary-arch binary-indep
- dh_testdir -a
- dh_testroot -a
- dh_install -a
- dh_installdocs -a
- dh_installchangelogs -a
- dh_strip -a
- dh_compress -a
- dh_fixperms -a
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
- # cargo install --root /usr --bin portspoof
- clean:
- dh_testdir
- dh_testroot
- dh_clean
- cargo clean
- # dh_make generated override targets
- # This is example for Cmake (See https://bugs.debian.org/641051 )
- #override_dh_auto_configure:
- # dh_auto_configure -- # -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
|