rules 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. #!/usr/bin/make -f
  2. # See debhelper(7) (uncomment to enable)
  3. # output every command that modifies files on the build system.
  4. #export DH_VERBOSE = 1
  5. # see FEATURE AREAS in dpkg-buildflags(1)
  6. #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  7. # see ENVIRONMENT in dpkg-buildflags(1)
  8. # package maintainers to append CFLAGS
  9. #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
  10. # package maintainers to append LDFLAGS
  11. #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
  12. build:
  13. cargo build --release
  14. binary-arch: build
  15. binary-indep: build
  16. binary: binary-arch binary-indep
  17. dh_testdir -a
  18. dh_testroot -a
  19. dh_install -a
  20. dh_installdocs -a
  21. dh_installchangelogs -a
  22. dh_systemd_enable -a
  23. dh_strip -a
  24. dh_compress -a
  25. dh_fixperms -a
  26. dh_installdeb -a
  27. dh_shlibdeps -a
  28. dh_gencontrol -a
  29. dh_md5sums -a
  30. dh_builddeb -a
  31. # cargo install --root /usr --bin portspoof
  32. clean:
  33. dh_testdir
  34. dh_testroot
  35. dh_clean
  36. cargo clean
  37. # dh_make generated override targets
  38. # This is example for Cmake (See https://bugs.debian.org/641051 )
  39. #override_dh_auto_configure:
  40. # dh_auto_configure -- # -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)